$re = '/^[^\r\n]+-flac\r?\n/m';
$str = 'http://6tor.org/torrent/899753/va-deep-dive-80s-pop-2022-mp3
http://6tor.org/torrent/899752/va-deep-dive-70s-pop-2022-mp3
http://6tor.org/torrent/899751/puscifer-kollekcija-2-albums-2022-flac
http://6tor.org/torrent/899749/classless-act-kollekcija-2-albums-2022-flac';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);