using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?<title>(?:[^\s\.]+\.){1}) +)*(?<first>\S+)(?: *(?<middle>[^,\n\r]+)*? +(?<last>[^,\s]+)*)*(?:, *(?<suffix>[^\n]+))*$";
string input = @"Ryan
Ryan William
Ryan William Toner
Mr. Ryan William Toner
Ryan William Corey Toner
Ryan William Corey Toner, Jr
Mr. Ryan William Corey Toner, Jr.
Dr. Ryan William Corey Toner, III
AJ
A.J.
A.J. Toner
Mr. AJ Toner
Mr. A.J. Christian Toner, Sr.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}