import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?<title>(?:[^\\s\\.]+\\.){1}) +)*(?<first>\\S+)(?: *(?<middle>[^,\\n\\r]+)*? +(?<last>[^,\\s]+)*)*(?:, *(?<suffix>[^\\n]+))*$";
final String string = "Ryan\n"
+ "Ryan William\n"
+ "Ryan William Toner\n"
+ "Mr. Ryan William Toner\n"
+ "Ryan William Corey Toner\n"
+ "Ryan William Corey Toner, Jr\n"
+ "Mr. Ryan William Corey Toner, Jr.\n"
+ "Dr. Ryan William Corey Toner, III\n"
+ "AJ\n"
+ "A.J.\n"
+ "A.J. Toner\n"
+ "Mr. AJ Toner\n"
+ "Mr. A.J. Christian Toner, Sr.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}