package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?<title>(?:[^\s\.]+\.){1}) +)*(?<first>\S+)(?: *(?<middle>[^,\n\r]+)*? +(?<last>[^,\s]+)*)*(?:, *(?<suffix>[^\n]+))*$`)
var str = `Ryan
Ryan William
Ryan William Toner
Mr. Ryan William Toner
Ryan William Corey Toner
Ryan William Corey Toner, Jr
Mr. Ryan William Corey Toner, Jr.
Dr. Ryan William Corey Toner, III
AJ
A.J.
A.J. Toner
Mr. AJ Toner
Mr. A.J. Christian Toner, Sr.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}