// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?<title>(?:[^\s\.]+\.){1}) +)*(?<first>\S+)(?: *(?<middle>[^,\n\r]+)*? +(?<last>[^,\s]+)*)*(?:, *(?<suffix>[^\n]+))*$").unwrap();
let string = "Ryan
Ryan William
Ryan William Toner
Mr. Ryan William Toner
Ryan William Corey Toner
Ryan William Corey Toner, Jr
Mr. Ryan William Corey Toner, Jr.
Dr. Ryan William Corey Toner, III
AJ
A.J.
A.J. Toner
Mr. AJ Toner
Mr. A.J. Christian Toner, Sr.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}