#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""loc": *"ar""
Local $sString = ""yuiwedw":{" & @CRLF & _
" "id":"yuiwedw"," & @CRLF & _
" "loc": "ar"," & @CRLF & _
" "body":{" & @CRLF & _
" "data":"we got this"," & @CRLF & _
" "loc":"ar"," & @CRLF & _
" "system":{" & @CRLF & _
" "fname":"admin"," & @CRLF & _
" "lname":"admin"," & @CRLF & _
" "details":[" & @CRLF & _
" {" & @CRLF & _
" "id":"Admin_01"," & @CRLF & _
" "loc":"ar"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "id":"Admin_02"," & @CRLF & _
" "loc":"ar"" & @CRLF & _
" }" & @CRLF & _
" ]" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" "hbjds324":{" & @CRLF & _
" "id":"hbjds324"," & @CRLF & _
" "loc": "ar"," & @CRLF & _
" "body":{" & @CRLF & _
" "data":"testing"," & @CRLF & _
" "loc":"ar"," & @CRLF & _
" "system":{" & @CRLF & _
" "fname":"public"," & @CRLF & _
" "lname":"servent"," & @CRLF & _
" "details":[" & @CRLF & _
" {" & @CRLF & _
" "id":"public_01"," & @CRLF & _
" "loc":"ar"" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "Available":true," & @CRLF & _
" "loc":"ar"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")