# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"loc\": *\"ar\""
test_str = ("\"yuiwedw\":{\n"
" \"id\":\"yuiwedw\",\n"
" \"loc\": \"ar\",\n"
" \"body\":{\n"
" \"data\":\"we got this\",\n"
" \"loc\":\"ar\",\n"
" \"system\":{\n"
" \"fname\":\"admin\",\n"
" \"lname\":\"admin\",\n"
" \"details\":[\n"
" {\n"
" \"id\":\"Admin_01\",\n"
" \"loc\":\"ar\"\n"
" },\n"
" {\n"
" \"id\":\"Admin_02\",\n"
" \"loc\":\"ar\"\n"
" }\n"
" ]\n"
" }\n"
" }\n"
" },\n"
" \"hbjds324\":{\n"
" \"id\":\"hbjds324\",\n"
" \"loc\": \"ar\",\n"
" \"body\":{\n"
" \"data\":\"testing\",\n"
" \"loc\":\"ar\",\n"
" \"system\":{\n"
" \"fname\":\"public\",\n"
" \"lname\":\"servent\",\n"
" \"details\":[\n"
" {\n"
" \"id\":\"public_01\",\n"
" \"loc\":\"ar\"\n"
" }\n"
" ],\n"
" \"Available\":true,\n"
" \"loc\":\"ar\"\n"
" }\n"
" }\n"
" }")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.