import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"loc\": *\"ar\"";
final String string = "\"yuiwedw\":{\n"
+ " \"id\":\"yuiwedw\",\n"
+ " \"loc\": \"ar\",\n"
+ " \"body\":{\n"
+ " \"data\":\"we got this\",\n"
+ " \"loc\":\"ar\",\n"
+ " \"system\":{\n"
+ " \"fname\":\"admin\",\n"
+ " \"lname\":\"admin\",\n"
+ " \"details\":[\n"
+ " {\n"
+ " \"id\":\"Admin_01\",\n"
+ " \"loc\":\"ar\"\n"
+ " },\n"
+ " {\n"
+ " \"id\":\"Admin_02\",\n"
+ " \"loc\":\"ar\"\n"
+ " }\n"
+ " ]\n"
+ " }\n"
+ " }\n"
+ " },\n"
+ " \"hbjds324\":{\n"
+ " \"id\":\"hbjds324\",\n"
+ " \"loc\": \"ar\",\n"
+ " \"body\":{\n"
+ " \"data\":\"testing\",\n"
+ " \"loc\":\"ar\",\n"
+ " \"system\":{\n"
+ " \"fname\":\"public\",\n"
+ " \"lname\":\"servent\",\n"
+ " \"details\":[\n"
+ " {\n"
+ " \"id\":\"public_01\",\n"
+ " \"loc\":\"ar\"\n"
+ " }\n"
+ " ],\n"
+ " \"Available\":true,\n"
+ " \"loc\":\"ar\"\n"
+ " }\n"
+ " }\n"
+ " }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}