import Foundation
let pattern = #""loc": *"ar""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"yuiwedw":{
"id":"yuiwedw",
"loc": "ar",
"body":{
"data":"we got this",
"loc":"ar",
"system":{
"fname":"admin",
"lname":"admin",
"details":[
{
"id":"Admin_01",
"loc":"ar"
},
{
"id":"Admin_02",
"loc":"ar"
}
]
}
}
},
"hbjds324":{
"id":"hbjds324",
"loc": "ar",
"body":{
"data":"testing",
"loc":"ar",
"system":{
"fname":"public",
"lname":"servent",
"details":[
{
"id":"public_01",
"loc":"ar"
}
],
"Available":true,
"loc":"ar"
}
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)