// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""loc": *"ar""#).unwrap();
let string = "\"yuiwedw\":{
\"id\":\"yuiwedw\",
\"loc\": \"ar\",
\"body\":{
\"data\":\"we got this\",
\"loc\":\"ar\",
\"system\":{
\"fname\":\"admin\",
\"lname\":\"admin\",
\"details\":[
{
\"id\":\"Admin_01\",
\"loc\":\"ar\"
},
{
\"id\":\"Admin_02\",
\"loc\":\"ar\"
}
]
}
}
},
\"hbjds324\":{
\"id\":\"hbjds324\",
\"loc\": \"ar\",
\"body\":{
\"data\":\"testing\",
\"loc\":\"ar\",
\"system\":{
\"fname\":\"public\",
\"lname\":\"servent\",
\"details\":[
{
\"id\":\"public_01\",
\"loc\":\"ar\"
}
],
\"Available\":true,
\"loc\":\"ar\"
}
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}