using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""loc"": *""ar""";
string input = @"""yuiwedw"":{
""id"":""yuiwedw"",
""loc"": ""ar"",
""body"":{
""data"":""we got this"",
""loc"":""ar"",
""system"":{
""fname"":""admin"",
""lname"":""admin"",
""details"":[
{
""id"":""Admin_01"",
""loc"":""ar""
},
{
""id"":""Admin_02"",
""loc"":""ar""
}
]
}
}
},
""hbjds324"":{
""id"":""hbjds324"",
""loc"": ""ar"",
""body"":{
""data"":""testing"",
""loc"":""ar"",
""system"":{
""fname"":""public"",
""lname"":""servent"",
""details"":[
{
""id"":""public_01"",
""loc"":""ar""
}
],
""Available"":true,
""loc"":""ar""
}
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}