using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=pow\().*?(?=,2\))";
string input = @"pow(alpha,2) + pow(beta,2)
3*pow(betaR_Full,2))
2/pow(betaDFull,3))
-pow(epsilon_gamma,2)+5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}