const regex = /(?<=pow\().*?(?=,2\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=pow\\().*?(?=,2\\))', 'gm')
const str = `pow(alpha,2) + pow(beta,2)
3*pow(betaR_Full,2))
2/pow(betaDFull,3))
-pow(epsilon_gamma,2)+5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}