re = /(?<=pow\().*?(?=,2\))/m
str = 'pow(alpha,2) + pow(beta,2)
3*pow(betaR_Full,2))
2/pow(betaDFull,3))
-pow(epsilon_gamma,2)+5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end