#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=&|>)([^&\r\n]{0,10}(?=&|<\/a>))*"
Local $sString = "<a>Health & Beauty</a>" & @CRLF & _
"<a href="https://website.com">Health & Beauty</a>" & @CRLF & _
"<a href="https://website.com">Health & Beauty 1 & Health & Beauty 1 </a>" & @CRLF & _
"<a>Health & Beauty 1 & Health & Beauty 1 </a>" & @CRLF & _
"<a>Health & Beauty 1 & Some other words & Beauty 1 & Some other words 2</a>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")