const regex = /(?<=&|>)([^&\r\n]{0,10}(?=&|<\/a>))*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=&|>)([^&\\r\\n]{0,10}(?=&|<\\\/a>))*', 'gm')
const str = `<a>Health & Beauty</a>
<a href="https://website.com">Health & Beauty</a>
<a href="https://website.com">Health & Beauty 1 & Health & Beauty 1 </a>
<a>Health & Beauty 1 & Health & Beauty 1 </a>
<a>Health & Beauty 1 & Some other words & Beauty 1 & Some other words 2</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}