import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=&|>)([^&\\r\\n]{0,10}(?=&|<\\/a>))*";
final String string = "<a>Health & Beauty</a>\n"
+ "<a href=\"https://website.com\">Health & Beauty</a>\n"
+ "<a href=\"https://website.com\">Health & Beauty 1 & Health & Beauty 1 </a>\n"
+ "<a>Health & Beauty 1 & Health & Beauty 1 </a>\n"
+ "<a>Health & Beauty 1 & Some other words & Beauty 1 & Some other words 2</a>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}