re = /(?<=&|>)([^&\r\n]{0,10}(?=&|<\/a>))*/m
str = '<a>Health & Beauty</a>
<a href="https://website.com">Health & Beauty</a>
<a href="https://website.com">Health & Beauty 1 & Health & Beauty 1 </a>
<a>Health & Beauty 1 & Health & Beauty 1 </a>
<a>Health & Beauty 1 & Some other words & Beauty 1 & Some other words 2</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end