import re
regex = re.compile(r"(?<=&|>)([^&\r\n]{0,10}(?=&|<\/a>))*", flags=re.MULTILINE)
test_str = ("<a>Health & Beauty</a>\n"
"<a href=\"https://website.com\">Health & Beauty</a>\n"
"<a href=\"https://website.com\">Health & Beauty 1 & Health & Beauty 1 </a>\n"
"<a>Health & Beauty 1 & Health & Beauty 1 </a>\n"
"<a>Health & Beauty 1 & Some other words & Beauty 1 & Some other words 2</a>\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")