#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\S+/)[A-Za-z]+_[A-Za-z]+(.*)"
Local $sString = "/asd/fdsadx/sadsa/ab_cd/myword?Id=953" & @CRLF & _
"/asd/fdsadx/sadsa/xx_yy?Id=953" & @CRLF & _
"/asd/fdsadx/sadsa/pp_qq/myword" & @CRLF & _
"/asd/fdsadx/sadsa/ab_cd" & @CRLF & _
"" & @CRLF & _
"/asd/fdsadx/sadsa//myword?Id=953" & @CRLF & _
"/asd/fdsadx/sadsa/?Id=953" & @CRLF & _
"/asd/fdsadx/sadsa//myword" & @CRLF & _
"/asd/fdsadx/sadsa/"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)