use strict;
my $str = '/asd/fdsadx/sadsa/ab_cd/myword?Id=953
/asd/fdsadx/sadsa/xx_yy?Id=953
/asd/fdsadx/sadsa/pp_qq/myword
/asd/fdsadx/sadsa/ab_cd
/asd/fdsadx/sadsa//myword?Id=953
/asd/fdsadx/sadsa/?Id=953
/asd/fdsadx/sadsa//myword
/asd/fdsadx/sadsa/';
my $regex = qr~^(\S+/)[A-Za-z]+_[A-Za-z]+(.*)~mp;
my $subst = '$1$2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";