import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+/)[A-Za-z]+_[A-Za-z]+(.*)";
final String string = "/asd/fdsadx/sadsa/ab_cd/myword?Id=953\n"
+ "/asd/fdsadx/sadsa/xx_yy?Id=953\n"
+ "/asd/fdsadx/sadsa/pp_qq/myword\n"
+ "/asd/fdsadx/sadsa/ab_cd\n\n"
+ "/asd/fdsadx/sadsa//myword?Id=953\n"
+ "/asd/fdsadx/sadsa/?Id=953\n"
+ "/asd/fdsadx/sadsa//myword\n"
+ "/asd/fdsadx/sadsa/";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}