// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\S+/)[A-Za-z]+_[A-Za-z]+(.*)").unwrap();
let string = "/asd/fdsadx/sadsa/ab_cd/myword?Id=953
/asd/fdsadx/sadsa/xx_yy?Id=953
/asd/fdsadx/sadsa/pp_qq/myword
/asd/fdsadx/sadsa/ab_cd
/asd/fdsadx/sadsa//myword?Id=953
/asd/fdsadx/sadsa/?Id=953
/asd/fdsadx/sadsa//myword
/asd/fdsadx/sadsa/";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}