re = /^(\S+\/)[A-Za-z]+_[A-Za-z]+(.*)/m
str = '/asd/fdsadx/sadsa/ab_cd/myword?Id=953
/asd/fdsadx/sadsa/xx_yy?Id=953
/asd/fdsadx/sadsa/pp_qq/myword
/asd/fdsadx/sadsa/ab_cd
/asd/fdsadx/sadsa//myword?Id=953
/asd/fdsadx/sadsa/?Id=953
/asd/fdsadx/sadsa//myword
/asd/fdsadx/sadsa/'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result