#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"(?P<ip>\d+\.\d+\.\d+\.\d+)[\n\r]" & @CRLF & _
"USER_NAME=(?P<user>.+)[\r\n]" & @CRLF & _
"PASSWORD=(?P<password>.+)"
Local $sString = "192.168.1.1" & @CRLF & _
"USER_NAME=admin" & @CRLF & _
"PASSWORD=admin123" & @CRLF & _
"" & @CRLF & _
"192.168.1.2" & @CRLF & _
"USER_NAME=user" & @CRLF & _
"PASSWORD=user123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")