package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
(?P<ip>\d+\.\d+\.\d+\.\d+)[\n\r]
USER_NAME=(?P<user>.+)[\r\n]
PASSWORD=(?P<password>.+)`)
var str = `192.168.1.1
USER_NAME=admin
PASSWORD=admin123
192.168.1.2
USER_NAME=user
PASSWORD=user123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}