import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?P<ip>\\d+\\.\\d+\\.\\d+\\.\\d+)[\\n\\r]\n"
+ "USER_NAME=(?P<user>.+)[\\r\\n]\n"
+ "PASSWORD=(?P<password>.+)";
final String string = "192.168.1.1\n"
+ "USER_NAME=admin\n"
+ "PASSWORD=admin123\n\n"
+ "192.168.1.2\n"
+ "USER_NAME=user\n"
+ "PASSWORD=user123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}