const regex = /^
(?P<ip>\d+\.\d+\.\d+\.\d+)[\n\r]
USER_NAME=(?P<user>.+)[\r\n]
PASSWORD=(?P<password>.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?P<ip>\\d+\\.\\d+\\.\\d+\\.\\d+)[\\n\\r]
USER_NAME=(?P<user>.+)[\\r\\n]
PASSWORD=(?P<password>.+)', 'gm')
const str = `192.168.1.1
USER_NAME=admin
PASSWORD=admin123
192.168.1.2
USER_NAME=user
PASSWORD=user123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}