import re
regex = re.compile(r"""
^
(?P<ip>\d+\.\d+\.\d+\.\d+)[\n\r]
USER_NAME=(?P<user>.+)[\r\n]
PASSWORD=(?P<password>.+)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("192.168.1.1\n"
"USER_NAME=admin\n"
"PASSWORD=admin123\n\n"
"192.168.1.2\n"
"USER_NAME=user\n"
"PASSWORD=user123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")