re = /^
(?P<ip>\d+\.\d+\.\d+\.\d+)[\n\r]
USER_NAME=(?P<user>.+)[\r\n]
PASSWORD=(?P<password>.+)/mx
str = '192.168.1.1
USER_NAME=admin
PASSWORD=admin123
192.168.1.2
USER_NAME=user
PASSWORD=user123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end