using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<label>\s*<input type=\""(\w+)\""\s*.+?value=\""(\d+)\"">(.+?)\/label";
string input = @" <div class=""form"">
<label>
<input type=""radio""
name=""options"" value=""55"">
a. XXXXXXXXXXX <br>
b. ZZZZZZZZZ<br>
c. MMMMMMMMM<br>
d. YYYYYYYYYYY<br>
e. AAAAAAAAA
</label>
<label>
<input type=""radio""
name=""options"" value=""56"">
a. XXXXXXXXXXX<br>
b. MMMMMMMMM<br>
c. YYYYYYYYYYY<br>
d. ZZZZZZZZZ<br>
e. AAAAAAAAA
</label>
<label>
<input type=""radio""
name=""options"" value=""57"">
a. XXXXXXXXXXX<br>
b. MMMMMMMMM<br>
c. YYYYYYYYYYY<br>
d. AAAAAAAAA<br>
e. ZZZZZZZZZ
</label>
</div>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}