import Foundation
let pattern = #"<label>\s*<input type=\"(\w+)\"\s*.+?value=\"(\d+)\">(.+?)\/label"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<div class="form">
<label>
<input type="radio"
name="options" value="55">
a. XXXXXXXXXXX <br>
b. ZZZZZZZZZ<br>
c. MMMMMMMMM<br>
d. YYYYYYYYYYY<br>
e. AAAAAAAAA
</label>
<label>
<input type="radio"
name="options" value="56">
a. XXXXXXXXXXX<br>
b. MMMMMMMMM<br>
c. YYYYYYYYYYY<br>
d. ZZZZZZZZZ<br>
e. AAAAAAAAA
</label>
<label>
<input type="radio"
name="options" value="57">
a. XXXXXXXXXXX<br>
b. MMMMMMMMM<br>
c. YYYYYYYYYYY<br>
d. AAAAAAAAA<br>
e. ZZZZZZZZZ
</label>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)