// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<label>\s*<input type=\"(\w+)\"\s*.+?value=\"(\d+)\">(.+?)\/label"#).unwrap();
let string = " <div class=\"form\">
<label>
<input type=\"radio\"
name=\"options\" value=\"55\">
a. XXXXXXXXXXX <br>
b. ZZZZZZZZZ<br>
c. MMMMMMMMM<br>
d. YYYYYYYYYYY<br>
e. AAAAAAAAA
</label>
<label>
<input type=\"radio\"
name=\"options\" value=\"56\">
a. XXXXXXXXXXX<br>
b. MMMMMMMMM<br>
c. YYYYYYYYYYY<br>
d. ZZZZZZZZZ<br>
e. AAAAAAAAA
</label>
<label>
<input type=\"radio\"
name=\"options\" value=\"57\">
a. XXXXXXXXXXX<br>
b. MMMMMMMMM<br>
c. YYYYYYYYYYY<br>
d. AAAAAAAAA<br>
e. ZZZZZZZZZ
</label>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}