$re = '/<label>\s*<input type=\"(\w+)\"\s*.+?value=\"(\d+)\">(.+?)\/label/s';
$str = ' <div class="form">
<label>
<input type="radio"
name="options" value="55">
a. XXXXXXXXXXX <br>
b. ZZZZZZZZZ<br>
c. MMMMMMMMM<br>
d. YYYYYYYYYYY<br>
e. AAAAAAAAA
</label>
<label>
<input type="radio"
name="options" value="56">
a. XXXXXXXXXXX<br>
b. MMMMMMMMM<br>
c. YYYYYYYYYYY<br>
d. ZZZZZZZZZ<br>
e. AAAAAAAAA
</label>
<label>
<input type="radio"
name="options" value="57">
a. XXXXXXXXXXX<br>
b. MMMMMMMMM<br>
c. YYYYYYYYYYY<br>
d. AAAAAAAAA<br>
e. ZZZZZZZZZ
</label>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);