const regex = /<label>\s*<input type=\"(\w+)\"\s*.+?value=\"(\d+)\">(.+?)\/label/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<label>\\s*<input type=\\"(\\w+)\\"\\s*.+?value=\\"(\\d+)\\">(.+?)\\\/label', 'gs')
const str = ` <div class="form">
<label>
<input type="radio"
name="options" value="55">
a. XXXXXXXXXXX <br>
b. ZZZZZZZZZ<br>
c. MMMMMMMMM<br>
d. YYYYYYYYYYY<br>
e. AAAAAAAAA
</label>
<label>
<input type="radio"
name="options" value="56">
a. XXXXXXXXXXX<br>
b. MMMMMMMMM<br>
c. YYYYYYYYYYY<br>
d. ZZZZZZZZZ<br>
e. AAAAAAAAA
</label>
<label>
<input type="radio"
name="options" value="57">
a. XXXXXXXXXXX<br>
b. MMMMMMMMM<br>
c. YYYYYYYYYYY<br>
d. AAAAAAAAA<br>
e. ZZZZZZZZZ
</label>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}