import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<label>\\s*<input type=\\\"(\\w+)\\\"\\s*.+?value=\\\"(\\d+)\\\">(.+?)\\/label";
final String string = " <div class=\"form\">\n\n\n"
+ " <label>\n"
+ " <input type=\"radio\"\n\n"
+ " name=\"options\" value=\"55\">\n"
+ " a. XXXXXXXXXXX <br>\n\n"
+ "b. ZZZZZZZZZ<br>\n\n"
+ "c. MMMMMMMMM<br>\n\n"
+ "d. YYYYYYYYYYY<br>\n\n"
+ "e. AAAAAAAAA\n"
+ " </label>\n\n"
+ " <label>\n"
+ " <input type=\"radio\"\n\n"
+ " name=\"options\" value=\"56\">\n"
+ " a. XXXXXXXXXXX<br>\n\n"
+ "b. MMMMMMMMM<br>\n\n"
+ "c. YYYYYYYYYYY<br>\n\n"
+ "d. ZZZZZZZZZ<br>\n\n"
+ "e. AAAAAAAAA\n"
+ " </label>\n\n"
+ " <label>\n"
+ " <input type=\"radio\"\n\n"
+ " name=\"options\" value=\"57\">\n"
+ " a. XXXXXXXXXXX<br>\n\n"
+ "b. MMMMMMMMM<br>\n\n"
+ "c. YYYYYYYYYYY<br>\n\n"
+ "d. AAAAAAAAA<br>\n\n"
+ "e. ZZZZZZZZZ\n"
+ " </label>\n\n\n\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}