# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bhttps?:\\/\\/.*\\///gm;t' <<< "https://example2.com/file/casdqwe/test1.rar
https://example2.com/file/casdqwe/test2.rar
https://example5.com/file/casdqwe/test3.rar
http://example2.com/file/casdqwe/test4.rar
http://www.example2.com/file/casdqwe/test5.rar
http://www.example5.com/file/casdqwe/test6.rar"