$re = '/\bhttps?:\/\/.*\//m';
$str = 'https://example2.com/file/casdqwe/test1.rar
https://example2.com/file/casdqwe/test2.rar
https://example5.com/file/casdqwe/test3.rar
http://example2.com/file/casdqwe/test4.rar
http://www.example2.com/file/casdqwe/test5.rar
http://www.example5.com/file/casdqwe/test6.rar';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;