import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bhttps?:\\/\\/.*\\/";
final String string = "https://example2.com/file/casdqwe/test1.rar\n"
+ "https://example2.com/file/casdqwe/test2.rar\n"
+ "https://example5.com/file/casdqwe/test3.rar\n"
+ "http://example2.com/file/casdqwe/test4.rar\n"
+ "http://www.example2.com/file/casdqwe/test5.rar\n"
+ "http://www.example5.com/file/casdqwe/test6.rar";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}