const regex = /\bhttps?:\/\/.*\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bhttps?:\\\/\\\/.*\\\/', 'gm')
const str = `https://example2.com/file/casdqwe/test1.rar
https://example2.com/file/casdqwe/test2.rar
https://example5.com/file/casdqwe/test3.rar
http://example2.com/file/casdqwe/test4.rar
http://www.example2.com/file/casdqwe/test5.rar
http://www.example5.com/file/casdqwe/test6.rar`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);