#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bhttps?:\/\/.*\/"
Local $sString = "https://example2.com/file/casdqwe/test1.rar" & @CRLF & _
"https://example2.com/file/casdqwe/test2.rar" & @CRLF & _
"https://example5.com/file/casdqwe/test3.rar" & @CRLF & _
"http://example2.com/file/casdqwe/test4.rar" & @CRLF & _
"http://www.example2.com/file/casdqwe/test5.rar" & @CRLF & _
"http://www.example5.com/file/casdqwe/test6.rar"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)