import Foundation
let pattern = #"\bhttps?:\/\/.*\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://example2.com/file/casdqwe/test1.rar
https://example2.com/file/casdqwe/test2.rar
https://example5.com/file/casdqwe/test3.rar
http://example2.com/file/casdqwe/test4.rar
http://www.example2.com/file/casdqwe/test5.rar
http://www.example5.com/file/casdqwe/test6.rar
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)