#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z]{2})?\d{6}(F|L|SDL?)?$"
Local $sString = "CA123456SDL" & @CRLF & _
"CA123456" & @CRLF & _
"123456" & @CRLF & _
"" & @CRLF & _
"C123456SDL" & @CRLF & _
"123456F" & @CRLF & _
"123456L" & @CRLF & _
"123456SD" & @CRLF & _
"123456SDL" & @CRLF & _
"123456SDL" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")