package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]{2})?\d{6}(F|L|SDL?)?$`)
var str = `CA123456SDL
CA123456
123456
C123456SDL
123456F
123456L
123456SD
123456SDL
123456SDL
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}