$re = '/^([a-zA-Z]{2})?\d{6}(F|L|SDL?)?$/m';
$str = 'CA123456SDL
CA123456
123456
C123456SDL
123456F
123456L
123456SD
123456SDL
123456SDL
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);