import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]{2})?\\d{6}(F|L|SDL?)?$";
final String string = "CA123456SDL\n"
+ "CA123456\n"
+ "123456\n\n"
+ "C123456SDL\n"
+ "123456F\n"
+ "123456L\n"
+ "123456SD\n"
+ "123456SDL\n"
+ "123456SDL\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}