// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z]{2})?\d{6}(F|L|SDL?)?$").unwrap();
let string = "CA123456SDL
CA123456
123456
C123456SDL
123456F
123456L
123456SD
123456SDL
123456SDL
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}