import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"email\\\\\\\\\\\\\\\":\\\\\\\\\\\\\\\".*?(?=,)";
final String string = "{\n"
+ " \\\\\\\"person\\\\\\\":{\\\\\\\"name\\\\\\\":{\\\\\\\"firstName\\\\\\\":\\\\\\\"John\\\\\\\",\\\\\\\"lastName\\\\\\\":\\\\\\\"Doe\\\\\\\"},\\\\\\\"address\\\\\\\":{\\\\\\\"street\\\\\\\":\\\\\\\"100 Main Ave\\\\\\\",\\\\\\\"city\\\\\\\":\\\\\\\"Redwood City\\\\\\\",\\\\\\\"usState\\\\\\\":\\\\\\\"CA\\\\\\\",\\\\\\\"zipCode\\\\\\\":\\\\\\\"94061\\\\\\\",\\\\\\\"country\\\\\\\":\\\\\\\"United States\\\\\\\",\\\\\\\"phones\\\\\\\":[],\\\\\\\"emails\\\\\\\":[],\\\\\\\"addressLines\\\\\\\":[]},\\\\\\\"addresses\\\\\\\":[],\\\\\\\"phones\\\\\\\":[{\\\\\\\"phoneType\\\\\\\":\\\\\\\"Home\\\\\\\",\\\\\\\"phoneNumber\\\\\\\":\\\\\\\"6500000000\\\\\\\"}],\\\\\\\"email\\\\\\\":\\\\\\\"johndoe@gmail.com\\\\\\\",\\\\\\\"dateOfBirth\\\\\\\":\\\\\\\"1900/01/01\\\\\\\",\\\\\\\"nationalId\\\\\\\":\\\\\\\"100\\\\\\\",\\\\\\\"gender\\\\\\\":\\\\\\\"Male\\\\\\\"},\\\\\\\"credential\\\\\\\":{\\\\\\\"userName\\\\\\\":\\\\\\\"johndoe@gmail.com\\\\\\\",\\\\\\\"password\\\\\\\":\\\\\\\"Password\\\\\\\",\\\\\\\"securityQuestion\\\\\\\":\\\\\\\"Name of First Car?\\\\\\\",\\\\\\\"securityAnswer\\\\\\\":\\\\\\\"Volvo\\\\\\\"}\\\"\"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}