import re
regex = re.compile(r"\"email\\\\\\\":\\\\\\\".*?(?=,)", flags=re.MULTILINE)
test_str = ("{\n"
" \\\\\\\"person\\\\\\\":{\\\\\\\"name\\\\\\\":{\\\\\\\"firstName\\\\\\\":\\\\\\\"John\\\\\\\",\\\\\\\"lastName\\\\\\\":\\\\\\\"Doe\\\\\\\"},\\\\\\\"address\\\\\\\":{\\\\\\\"street\\\\\\\":\\\\\\\"100 Main Ave\\\\\\\",\\\\\\\"city\\\\\\\":\\\\\\\"Redwood City\\\\\\\",\\\\\\\"usState\\\\\\\":\\\\\\\"CA\\\\\\\",\\\\\\\"zipCode\\\\\\\":\\\\\\\"94061\\\\\\\",\\\\\\\"country\\\\\\\":\\\\\\\"United States\\\\\\\",\\\\\\\"phones\\\\\\\":[],\\\\\\\"emails\\\\\\\":[],\\\\\\\"addressLines\\\\\\\":[]},\\\\\\\"addresses\\\\\\\":[],\\\\\\\"phones\\\\\\\":[{\\\\\\\"phoneType\\\\\\\":\\\\\\\"Home\\\\\\\",\\\\\\\"phoneNumber\\\\\\\":\\\\\\\"6500000000\\\\\\\"}],\\\\\\\"email\\\\\\\":\\\\\\\"johndoe@gmail.com\\\\\\\",\\\\\\\"dateOfBirth\\\\\\\":\\\\\\\"1900/01/01\\\\\\\",\\\\\\\"nationalId\\\\\\\":\\\\\\\"100\\\\\\\",\\\\\\\"gender\\\\\\\":\\\\\\\"Male\\\\\\\"},\\\\\\\"credential\\\\\\\":{\\\\\\\"userName\\\\\\\":\\\\\\\"johndoe@gmail.com\\\\\\\",\\\\\\\"password\\\\\\\":\\\\\\\"Password\\\\\\\",\\\\\\\"securityQuestion\\\\\\\":\\\\\\\"Name of First Car?\\\\\\\",\\\\\\\"securityAnswer\\\\\\\":\\\\\\\"Volvo\\\\\\\"}\\\"\"\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")