const regex = /\"email\\\\\\\":\\\\\\\".*?(?=,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"email\\\\\\\\\\\\\\":\\\\\\\\\\\\\\".*?(?=,)', 'gm')
const str = `{
\\\\\\"person\\\\\\":{\\\\\\"name\\\\\\":{\\\\\\"firstName\\\\\\":\\\\\\"John\\\\\\",\\\\\\"lastName\\\\\\":\\\\\\"Doe\\\\\\"},\\\\\\"address\\\\\\":{\\\\\\"street\\\\\\":\\\\\\"100 Main Ave\\\\\\",\\\\\\"city\\\\\\":\\\\\\"Redwood City\\\\\\",\\\\\\"usState\\\\\\":\\\\\\"CA\\\\\\",\\\\\\"zipCode\\\\\\":\\\\\\"94061\\\\\\",\\\\\\"country\\\\\\":\\\\\\"United States\\\\\\",\\\\\\"phones\\\\\\":[],\\\\\\"emails\\\\\\":[],\\\\\\"addressLines\\\\\\":[]},\\\\\\"addresses\\\\\\":[],\\\\\\"phones\\\\\\":[{\\\\\\"phoneType\\\\\\":\\\\\\"Home\\\\\\",\\\\\\"phoneNumber\\\\\\":\\\\\\"6500000000\\\\\\"}],\\\\\\"email\\\\\\":\\\\\\"johndoe@gmail.com\\\\\\",\\\\\\"dateOfBirth\\\\\\":\\\\\\"1900/01/01\\\\\\",\\\\\\"nationalId\\\\\\":\\\\\\"100\\\\\\",\\\\\\"gender\\\\\\":\\\\\\"Male\\\\\\"},\\\\\\"credential\\\\\\":{\\\\\\"userName\\\\\\":\\\\\\"johndoe@gmail.com\\\\\\",\\\\\\"password\\\\\\":\\\\\\"Password\\\\\\",\\\\\\"securityQuestion\\\\\\":\\\\\\"Name of First Car?\\\\\\",\\\\\\"securityAnswer\\\\\\":\\\\\\"Volvo\\\\\\"}\\""
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}